Upgrade Browser

Experiencing laggy internet banking sessions recently?

This could be caused by an outdated browser. Please ensure that your browser meet the minimum version supported version as follows:- 

  • Google Chrome: Version 30 or higher
  • Internet Explorer: Version 11
  • Mozilla Firefox: Version 27 or higher
  • Opera: Version 17 or higher
  • Safari: Version 7 or higher

Why you should update your browser:
1. Security
    The latest browsers protect you against new viruses, Trojans and other threats.
2. Speed
    You will experience a smoother online banking session.
3. Compatibility
    Website interfaces will be displayed more accurately.
4. User-friendliness
    New browsers typically come with new features, extensions and better customisability which will improve your overall web surfing experience.

 

Click on the links below to download now.

Chrome Mozilla
Safari Opera                       
Internet Explorer 11